Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000079Pogamut 3Pogamut yaPOSHpublic2013-05-23 17:382013-08-12 16:54
Reportermichal.bida 
Assigned Tohonza.havlicek 
PriorityhighSeveritymajorReproducibilityalways
StatusassignedResolutionfixed 
PlatformOSOS Version
Product Version3.5.2-SNAPSHOT 
Target Version3.5.2-SNAPSHOTFixed in Version 
Summary0000079: When no action is selected in yaPOSH, plan SHOULD NOT be re-evaluated
DescriptionIf the whole plan is processed and no action is selected, the POSH plan should NOT be re-evaluated. It has two problems:
1) It creates infinite cycle. When no action was selected in previous run and the re-evaluation is triggered immediately, all senses will have the same value as before (no update from environment can arrive due to POSH lock), so no action gets chosen again and infinite cycle is created.
2) This behavior is suprising and not intuitive. If my POSH plan does not select an action in one iteration I don't expect it to enter infinite loop distrubting updates from the evnironment.
TagsNo tags attached.
Attached Filespng file icon YaPOSH-StrangeExecution.png [^] (234,318 bytes) 2013-08-12 16:53

- Relationships

-  Notes
(0000058)
honza.havlicek (developer)
2013-06-17 17:00

Fixed in commit #6193. The iteration of the engine now also ends when no element was fires or when goal of the plan was fulfilled.
(0000083)
jakub.gemrot (administrator)
2013-08-12 16:53

Okey, it works, but the execution semantics is extremely fishy...

- Issue History
Date Modified Username Field Change
2013-05-23 17:38 michal.bida New Issue
2013-05-23 17:38 michal.bida Status new => assigned
2013-05-23 17:38 michal.bida Assigned To => honza.havlicek
2013-06-17 17:00 honza.havlicek Note Added: 0000058
2013-06-17 17:00 honza.havlicek Status assigned => resolved
2013-06-17 17:00 honza.havlicek Resolution open => fixed
2013-08-12 16:53 jakub.gemrot Note Added: 0000083
2013-08-12 16:53 jakub.gemrot File Added: YaPOSH-StrangeExecution.png
2013-08-12 16:54 jakub.gemrot Status resolved => assigned


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker